【Plesk经验分享】无法安装或更新Plesk怎么办?

适用版本:Plesk for Linux

症状

无法安装或更新Plesk,同时出现以下错误之一:

1.

 

2. 

 

3.

 

4.

 

5.

此外,也不能使用wget下载文件:

原因

1. Plesk使用的是内容交付网络(CDN)来分发Plesk软件包。这一技术会使用多个缓存服务器,而这些服务器是分布在网络的不同部分的。所有这些服务器都会共享一个共同的域名autoinstall.plesk.com,根据请求来自的网络段的不同,该域名会解析到不同的IP地址。有时,服务器与主副本不同步,文件因此会丢失。

2. 网络或防火墙问题。

解决办法

使用Plesk仓库的主副本,直到本地CDN服务器与它同步了。要做到这一点,则在文件/etc/hosts中配置一个静态的解析规则:

1. 通过SSH连接到服务器

2. 打开/etc/hosts文件进行编辑,例如,使用vim文本编辑器:

3. 在其中插入以下行,以强制将Plesk的安装程序解析到主副本:

如果这没有任何帮助,请联系网络管理员来检查为什么服务器无法抵达Plesk。

在某些情况下,禁用TCP窗口扩展也有所帮助:

echo 0 > /proc/sys/net/ipv4/tcp_window_scaling

提交
还没有评论,快来抢沙发吧!
售前
支持
代理
合作
售后
支持